Debugar en Sandbox

Etiquetado: 

Este debate contiene 9 respuestas, tiene 3 mensajes y lo actualizó  Jaime Capilla hace 2 semanas, 1 día.

Viendo 10 publicaciones - del 1 al 10 (de un total de 10)
  • Autor
    Publicaciones
  • #14255

    Jaime Capilla
    Participante

    Hola!

    ¿Se puede debugar en el Sandbox de un Cloud de BC 15? Yo no lo consigo y he estado leyendo en varios lugares tanto que si que se puede como que no se puede.

    ¿Alguien sabe si es posible y si hay que hacer algo especial o si por el contrario, esperemos que de momento, no es posible?

    #14257

    Sergio
    Participante

    Si se podía en la 14, ¿porque no se iba a poder en la 15? Yo he debugueado en las dos sin problemas.

    #14258

    BETEA
    Participante

    Apunta en el launch.json al sandbox soer el que queires publicar, y publicas la extension desde VScode con f5

    #14259

    BETEA
    Participante

    Apunta en el launch.json al sandbox sobre el que queires publicar, y publicas la extension desde VScode con f5

    #14260

    Jaime Capilla
    Participante

    En le launch.json tengo «name»: «Sandbox» y «server»: «https://businesscentral.dynamics.com/xxxxxxxxxxxxx/Sandbox». La publico desde VSCode con F5 pero no debuga. ¿Hay que tener algún valor en concreto en los json?

    #14261

    BETEA
    Participante
    #14262

    Jaime Capilla
    Participante

    Gracias por tu respuesta BETEA.

    Había encontrado esta pagina y he probado ambas configuraciones a pesar de solo tener un Sandbox, y nada.

    Mi launch es

    {
    «version»: «0.2.0»,
    «configurations»: [
    {
    «name»: «Microsoft cloud sandbox»,
    «type»: «al»,
    «request»: «launch»,
    «startupObjectId»: 50100,
    «startupObjectType»: «Page»,
    «breakOnError»: true,
    «breakOnRecordWrite»: false,
    «launchBrowser»: true,
    }
    ]
    }

     

    Usando el sandboxname y el tenant tampoco me debuga. Solo lo publica. No sé que puede estar pasando.

    #14263

    BETEA
    Participante

    has puesto el showmycode a true en el app,json?

    #14264

    Jaime Capilla
    Participante

    Si. Lo pego por si hubiera algún problema.

    {
    «id»: «f9ea6d41-2b32-4a3d-823c-11248d578704»,
    «name»: «Archivos»,
    «publisher»: «Default publisher»,
    «version»: «1.0.0.0»,
    «brief»: «»,
    «description»: «»,
    «privacyStatement»: «»,
    «EULA»: «»,
    «help»: «»,
    «url»: «»,
    «logo»: «»,
    «dependencies»: [
    {
    «appId»: «437dbf0e-84ff-417a-965d-ed2bb9650972»,
    «version»: «15.0.0.0»,
    «name»: «Base Application»,
    «publisher»: «Microsoft»
    },
    {
    «appId»: «63ca2fa4-4f03-4f2b-a480-172fef340d3f»,
    «version»: «15.0.0.0»,
    «name»: «System Application»,
    «publisher»: «Microsoft»
    }
    ],
    «screenshots»: [],
    «platform»: «15.0.0.0»,
    «idRanges»: [
    {
    «from»: 50100,
    «to»: 50149
    }
    ],
    «contextSensitiveHelpUrl»: «https://Archivos.com/help/»,
    «showMyCode»: true,
    «runtime»: «4.0»,
    «features»: [«TranslationFile»]
    }

    #14268

    Jaime Capilla
    Participante

    Hola!

    Al final, probando en otra maquina he podido debugar sin problema. Estaba probando en un W7 por lo que me inclino a pensar que es culpa del operativo. He encontrado esta pagina por si a alguien le es de utilidad.

    https://community.dynamics.com/business/f/dynamics-365-business-central-forum/370681/info-how-to-debug-on-business-central-cloud-version

    Muchas gracias por la ayuda.

     

Viendo 10 publicaciones - del 1 al 10 (de un total de 10)

Debes estar registrado para responder a este debate.

Members Currently Active: 2
DATANET, jmp
Keymaster | Moderator | Participant | Spectator | Blocked
Additional Forum Statistics
Threads: 1.028, Posts: 3.244, Members: 993
Welcome to our newest member, ACUSTICA
Most users ever online was 15 on 5 April, 2019 9:31 am