Error Migración 2015

Etiquetado: ,

Este debate contiene 4 respuestas, tiene 2 mensajes y lo actualizó  Laura Nicolàs hace 1 año, 1 mes.

Viendo 5 publicaciones - del 1 al 5 (de un total de 5)
  • Autor
    Publicaciones
  • #4923

    jose navarro gonzalez
    Participante

    Hola,

    Tengo la siguiente duda en un proceso de la migración de 2009R2 a 2017:
    Una vez he compilado todas los objetos(sincronización Later) y arreglo los errores que me aparecen, recompilo y ya no hay errores.

    Realizo la sincronización del esquema a través del PowerShell y me da un error nada mas lanzarla. Muchas líneas en rojo sin especificar el fallo.

    Os ha pasado a vosotras algo parecido?

    Gracias anticipadas.

    Saludos,

    #4924

    jose navarro gonzalez
    Participante

    Además me da error cada vez que ejecuto el cliente.

    #4925

    Laura Nicolàs
    Jefe de claves

    Jose,

    El cliente no lo vas a poder abrir hasta que no esté todo sincronizado.

    Lo de los errores que comentes, si que me ha pasado alguna vez. Lo que hago en estos casos, y más si los mensajes de error no me dan pistas, es ir sincronizando tabla a tabla, hasta encontrar dónde está el problema.

    1. Desde C/SIDE, selecciona y compila las tablas de sistema. De esta forma compilas y sincronizas.
    2. Desde C/SIDE, emepieza a compilar las tablas 1 a 1 (o en bloques de 10 o 100, como tu prefieras). Selecciona Sync ahora. En aquellas tablas que te de error porque se eliminan campos, revisar qué campos son, y si estás conforme, compila con el sync a Force.

    Con esto acabarás encontrando qué tabla es la que da problemas de sincronización, y tendrás más pistas sobre como solucionar el problema.

    En el curso de Upgrade de datos a NAV2018, explico éste y otros truquillos!

    Espero haber ayudado.

    Salut!
    Laura Nicolàs

    Curso presencial. Conviértete en un Experto en Business Central. Para futuros consultores y futuros programadores. Empezamos de cero.

    Curso organizado como un máster.
    Inicio del curso: 26 de Abril
    Más información

    #4937

    jose navarro gonzalez
    Participante

    Hola Laura,

    Muchas gracias, al sincronizar las tablas una a una a funcionado.

    Otra duda, ahora ya estoy en NAV 2017 y cuando compilo todos los objetos me dan error las tablas: UPG Item, UPG Job y otras UPG.

    El error es: «Ya hay un objeto con el nombre ‘Empresa$UPG Item’ en la base de datos»

    Sabes porqué puede ser?

    Gracias anticipadas.

    Saludos,

    #4939

    Laura Nicolàs
    Jefe de claves

    Si, eso me pasó en una de las lecciones y lo expliqué.

    El tema es algo así:
    Tienes una tabla con un ID (digamos 111) que se llama «UPG Item»
    Después cargas un fob que:
    – A la tabla 111 le pasa a llamar «UPG Cualquier otro nombre»
    – Crea la tabla 222 y la llama «UPG Item»

    Como todavía no se ha hecho la sincronización:
    – En SQL (o en los metadatos) sigue teniendo la referencia a la tabla 111 UPG Item, aunque desde C/SIDE no lo ves.
    – Al sincronizar la tabla 222 (y si todavía no se ha sincronizado la 111) te dice que ya hay otra tabla con el mismo nombre.

    Solución:
    Cambia el nombre de la tabla «UPG Item» que hay en C/SIDE. Ponle «UPG Item 2» o lo que sea.

    Salut!
    Laura Nicolàs

    Curso presencial. Conviértete en un Experto en Business Central. Para futuros consultores y futuros programadores. Empezamos de cero.

    Curso organizado como un máster.
    Inicio del curso: 26 de Abril
    Más información

Viendo 5 publicaciones - del 1 al 5 (de un total de 5)

Debes estar registrado para responder a este debate.

Members Currently Active: 0
No users are currently active
Keymaster | Moderator | Participant | Spectator | Blocked
Additional Forum Statistics
Threads: 730, Posts: 2.414, Members: 813
Welcome to our newest member, GCG
Most users ever online was 15 on 5 April, 2019 9:31 am