report en NAS

Este debate contiene 2 respuestas, tiene 2 mensajes y lo actualizó  Javier Téllez Martín hace 1 año, 3 meses.

Viendo 3 publicaciones - del 1 al 3 (de un total de 3)
  • Autor
    Publicaciones
  • #5887

    Buenos días,

    He puesto un report (es sólo de proceso) para que se ejecute todos los días a las 21. No está funcionando en el NAS (versión 2017).

    Me han comentado que puede ser porque tiene puesto «Use Request Page» y un mensaje al finalizar el proceso.

    Mi pregunta es si esa es la solución correcta o crearme una codeunit y llamar a ese report

    Muchísimas gracias,

    Javier

    #5888

    Cristina Nicolàs
    Jefe de claves

    Hola Javier,

    Es correcto poner un report en el NAS.
    Pero como bien dices, seguro que te falla por el RequestPage y por el MESSAGE.

    Tendrías que quitar la RequestPage y el message hacerlo condicional:

    IF GUIALLOWED THEN
    MESSAGE

    Si este report también lo utilizan los usuarios y no puedes quitar la RequestPage, entonces quizá sí que deberías crear otro objeto (una codeunit por ejemplo), que haga una llamada al report sin RequestPage, y poner la codeunit en el NAS.

    Un saludo,
    Cristina Nicolàs

    ¿Quieres conocer las últimas novedades sobre Business Central? Dynamics ScaleUp 2019.

    Consulta fechas en
    DynamicsScaleUp.com

    #5889

    Hola Cristina,

    Muchísimas gracias por la información. En principio creo que no van a necesitar el request page porque no van a poner ningún filtro y para el mensaje he puesto la función GUIALLOWED como me has dicho.

    Saludos,

    Javier

Viendo 3 publicaciones - del 1 al 3 (de un total de 3)

Debes estar registrado para responder a este debate.

Members Currently Active: 2
Javier-Rodilla, softymax
Keymaster | Moderator | Participant | Spectator | Blocked
Additional Forum Statistics
Threads: 921, Posts: 2.969, Members: 925
Welcome to our newest member, Khron0s
Most users ever online was 15 on 5 April, 2019 9:31 am